Routage dynamique RIP

Routage dynamique RIP

Après vous avoir parlé du routage statique, je vais vous présenter dans cet article le routage dynamique et je vais vous montrer comment mettre en place une infrastructure avec le protocole de routage RIP.




Routage dynamique

Explication

Contrairement au routage statique, le routage dynamique ne nécessite pas de constante mise à jour de configuration dès lors qu’un changement de topologie intervient sur votre réseau. Le routage dynamique va faciliter le maintien du routage de votre réseau en faisant les changements nécessaires automatiquement. Il existe plusieurs protocoles de routage, dans cet article je vais vous expliquer comment mettre en place RIP mais il en existe d’autres.

 

Type

Sachez qu’il existe deux types de protocoles de routage dynamique:

  • Les protocoles externes (EGP) sont les protocoles de routage externe, leurs rôles et de relier deux systèmes autonomes différents. Un système autonome est un « réseau » dont la politique de routage est la même. Chaque système autonome possède une structure de routage indépendante.
    Exemple de protocole: BGP
  • Les protocoles internes (IGP) permettent quant à eux d’établir des routes entre les points du réseau d’un système autonome. Si une modification de topologie apparaît sur le réseau ces protocoles vont mettre à jour le routage afin de rétablir la connectivité si une route possible existe bien sur.
    Exemples de protocole: RIP et OSPF

 

Passons maintenant à la pratique, lors de ce tutoriel je vais utiliser des routeurs de marque Cisco.

 

RIP

Deux types

Il existe deux versions de ce protocole:

  • RIPv1: cette version n’envoie pas les informations sur les masques réseaux. Elle va par défaut se servir des masques utilisés dans les classes d’adresses IP. Par exemple, si vous utilisez le réseau 10.0.0.0/24, RIPv1 va l’interpréter comme 10.0.0.0/8. Autre particularité de cette version, elle envoie ses mises en broadcast c’est-à-dire à tout votre réseau.
  • RIPv2 lui gère les masques réseaux et effectue ses mises à jour en multicast (sur 224.0.0.9).

 

Inconvénients:

  • Le nombre de saut est limité à 15 afin d’éviter les boucles réseaux (un saut est le passage d’un équipement à un autre).
  • Le protocole se base uniquement sur le nombre de saut. Par exemple sur le schéma ci-dessous, si les deux PC souhaitent échanger des données le chemin du bas est beaucoup plus rapide. Mais ce chemin contenant plus de nombre de saut que celui du haut, RIP va faire transiter les données sur ce lien même s’il est plus lent.

 

Configuration

Nous allons mettre en place l’architecture suivante en RIPv2:

L’objectif, vous l’aurez compris est que PC1 et PC2 puissent communiquer ensemble. Commençons par configurer les adresses IP des interfaces:

  • R1
     Router(config)#hostname R1
     R1(config)#interface g0/0
     R1(config-if)#ip address 192.168.1.1 255.255.255.0
     R1(config-if)#no shutdown
     R1(config-if)#interface g0/1
     R1(config-if)#ip address 10.0.0.1 255.255.255.252
     R1(config-if)#no shutdown
     R1(config-if)#interface g0/2
     R1(config-if)#ip address 10.0.0.5 255.255.255.252
     R1(config-if)#no shutdown
  • R2
     Router(config)#hostname R2
     R2(config)#interface g0/0
     R2(config-if)#ip address 172.18.1.1 255.255.255.0
     R2(config-if)#no shutdown
     R2(config-if)#interface g0/1
     R2(config-if)#ip address 10.0.0.2 255.255.255.252
     R2(config-if)#no shutdown
     R2(config-if)#interface g0/2
     R2(config-if)#ip address 10.0.0.10 255.255.255.252
     R2(config-if)#no shutdown
  • R3
     Router(config)#hostname R3
     R3(config)#interface g0/0
     R3(config-if)#ip address 10.0.0.6 255.255.255.252
     R3(config-if)#no shutdown
     R3(config-if)#interface g0/1
     R3(config-if)#ip address 10.0.0.9 255.255.255.252
     R3(config-if)#no shutdown
  • Configuration PC1 et PC2:

    On affecte l’IP 192.168.1.2 avec le masque 255.255.255.0 et comme passerelle 192.168.1.1 à PC1 et l’IP 172.18.1.2 avec le masque 255.255.255.0 et comme passerelle 172.18.1.1 à PC2.

Passons à la configuration du routage RIP:

  • R1
    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#no auto-summary
    R1(config-router)#passive-interface g0/0
    R1(config-router)#network 10.0.0.0
    R1(config-router)#network 192.168.1.0
  • R2
    R1(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#no auto-summary
    R2(config-router)#passive-interface g0/0
    R2(config-router)#network 10.0.0.0
    R2(config-router)#network 172.18.1.0
  • R3
    R3(config)#router rip
    R3(config-router)#version 2
    R3(config-router)#no auto-summary
    R3(config-router)#network 10.0.0.0

Explications sur les commandes utilisées:

no auto-summary désactive le résumé automatique des routes dans la table de routage de l’équipement.

network X.X.X.X signifie que ce réseau va être diffusé.

passive-interface X n’est pas indispensable c’est de la sécurité, elle désactive l’envoi de mise à jour RIP sur l’interface spécifiée. Dans notre cas inutile d’envoyer les mises à jour RIP aux réseaux locaux, c’est d’ailleurs une faille de sécurité une personne pourrait les intercepter.

 

Test

Réalisez les vérifications ci-dessous  afin de valider que votre configuration fonctionne:

Commencez par faire un ping entre vos deux machines:

Si vos équipements peuvent communiquer ensemble c’est bon signe. Sinon effectuez les vérifications ci-dessous:

  • R1
    R1#show ip route

La table de routage doit contenir:

R 10.0.0.8/30 [120/1] via 10.0.0.2, 00:00:11, GigabitEthernet0/1
[120/1] via 10.0.0.6, 00:00:19, GigabitEthernet0/2

R 172.18.1.0/24 [120/1] via 10.0.0.2, 00:00:11, GigabitEthernet0/1
  • R2
    R2#show ip route

La table de routage doit contenir:

R 10.0.0.4/30 [120/1] via 10.0.0.1, 00:00:18, GigabitEthernet0/1
[120/1] via 10.0.0.9, 00:00:04, GigabitEthernet0/2

R 192.168.1.0/24 [120/1] via 10.0.0.1, 00:00:18, GigabitEthernet0/1
  • R3
    R3#show ip route

La table de routage doit contenir:

R 172.18.1.0/24 [120/1] via 10.0.0.10, 00:00:08, GigabitEthernet0/1
R 192.168.1.0/24 [120/1] via 10.0.0.5, 00:00:18, GigabitEthernet0/0

 

Le « R » devant la route symbolise que celle-ci a été apprise par le protocole RIP. Vous pouvez déconnecter des câbles réseaux afin de voir les mises à jour de la table de routage de vos équipements.

 

C’est la fin de ce tutoriel sur le protocole de routage dynamique RIP, n’hésitez pas à consulter mes articles sur le routage statique ou sur le routage dynamique ospf si vous souhaitez en savoir d’avantage.

À propos de l’auteur

Vincent Krahenbuhl administrator

Passionné d’informatique, ma motivation et ma curiosité m’ont permis de réaliser des études en alternance, tout d’abord en tant que technicien informatique au sein du groupe Edscha puis administrateur réseau au sein de FM Logistic. Fort de ces expériences dans deux entreprises internationales, j’exerce aujourd’hui le rôle d’ingénieur réseau et sécurité chez FM Logistic.

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.