Routage Statique

Routage Statique

Cet article va vous permettre de comprendre les principes de base du routage statique mais aussi de vous montrer comment mettre en place une infrastructure réseau simple en utilisant celui-ci. Un QCM est à la fin de l’article pour tester vos connaissances.




Explication

Le routage permet a deux réseaux distincts de communiquer entre eux pour assurer le transfert de paquets d’une source à une destination. Les routeurs sont les équipements réseaux qui vont assurer ce rôle. Dans le cadre du routage statique, les réseaux distants devront être saisis manuellement dans la table de routage du routeur appelées routes statiques.

Le routage statique présente des avantages par rapport au routage dynamique, les routes statiques ne sont pas diffusées sur le réseau ce qui offre un gain en sécurité, la bande passante est moins utilisée qu’avec un routage dynamique car celui-ci va calculer continuellement les routes. Mais il présente aussi des inconvénients, la configuration de base et la maintenance de celle-ci prend du temps. De ce fait, la mise à jour des routes doit se faire manuellement et n’est pas optimale pour les grands réseaux.

Voici ce qu’il se passe si les routes ne sont pas correctement renseignées:

Mise en place

Nous allons maintenant implémenter le routage statique dans le réseau suivant:

Implémentation du routage statique

Nous allons commencer par paramétrer les IP sur les interfaces des différents équipements (f0/1, g0/0…). Pour cela passez en mode configuration et saisissez les commandes suivantes:

  • Configuration R1:
    Router(config)#hostname R1
    R1(config)#interface gigabitEthernet 0/1
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#interface g0/0
    R1(config-if)#ip address 10.0.0.1 255.255.255.0
    R1(config-if)#no shutdown
  • Configuration R2:
    Router(config)#hostname R2
    R2(config)#interface gigabitEthernet 0/1
    R2(config-if)#ip address 172.16.0.1 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#interface g0/0
    R2(config-if)#ip address 10.0.0.2 255.255.255.0
    R2(config-if)#no shutdown
  • Configuration PC1 et PC2:
    On affecte l’IP 192.168.1.5 avec le masque 255.255.255.0 à PC1 et l’IP 172.16.0.5 avec le masque 255.255.255.0 à PC2

La configuration IP est maintenant finie, pourtant on remarque que PC1 et PC2 ne sont toujours pas capables de communiquer entre-eux. En effet, les routeurs apprennent les réseaux directement connectés mais en ce qui concerne les réseaux distants avec le routage statique ils doivent être saisis manuellement, un par un.

Nous allons donc indiquer à R1 que le réseau 172.16.0.0/24 existe et au routeur R2 que le réseau 192.168.1.0/24 existe afin que les PC puissent communiquer entre-eux. Nous allons pour cela utiliser la commande:

ip route [IP réseau distant] [masque du réseau distant] [IP prochain saut]

  • R1

R1(config)#ip route 172.16.0.0 255.255.255.0 10.0.0.2

  • R2

R2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1

Le réseau est maintenant configuré et fonctionnel, PC1 et PC2 peuvent communiquer entre-eux grâce à la mise en place du routage statique.

A savoir qu’il est également possible de configurer une route par défaut:

ip route 0.0.0.0 0.0.0.0 [IP prochain saut]

Cette commande signifie que tout les packets reçus seront envoyés vers l’IP de prochain saut et ce peu importe le réseau de provenance. Le premier 0.0.0.0 symbolise toute les IP, le second tout les masques réseaux. Cette commande est principalement utilisée sur les routeurs d’extrémité de réseau.

QCM

Vérifies que tu as compris le routage statique avec ce QCM

A quoi sert le routage statique?

Je viens de configurer tous les équipements malgré cela PC1 et PC2 ne peuvent toujours pas communiquer, pourtant les routes statiques configurées sur les routeurs sont correctes. D'où vient le problème?

QCM

Compléter la configuration de la route de R2:

QCM2

Compléter la configuration des routes de R2  pour joindre les réseaux 172.29.0.0/24 et 192.168.1.0/24 (2 bonnes réponses à sélectionner):


À propos de l’auteur

Vincent Krahenbuhl administrator

Passionné d’informatique, ma motivation et ma curiosité m’ont permis de réaliser des études en alternance, tout d’abord en tant que technicien informatique au sein du groupe Edscha puis administrateur réseau au sein de FM Logistic. Fort de ces expériences dans deux entreprises internationales, j’exerce aujourd’hui le rôle d’ingénieur réseau et sécurité chez FM Logistic.

1 commentaire pour l’instant

M. KONATEPublié le11:38 - Oct 16, 2018

Bonjour,
J’ai beaucoup aimé votre site web, les explications sont assez claires, je comprends facilement les concepts.
Cependant, quelques conseils et astuces de votre part pour mieux retenir les notions seront les bienvenus.

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.