Routage dynamique OSPF

Routage dynamique OSPF

Je vais vous présenter dans cet article le protocole de routage dynamique OSPF (Open Shortest Path First) et je vais vous montrer comment mettre celui-ci en place une infrastructure réseau.




 

OSPF

Contrairement au protocole de routage RIP que je vous ai présenté dans un autre article, OSPF ne va pas utiliser le chemin comportant le minimum de saut mais le plus rapide.

 

Configuration

Nous allons mettre en place l’architecture suivante avec le protocole de routage dynamique OSPF :

L’objectif, vous l’aurez compris est que PC1 et PC2 puissent communiquer ensemble. Commençons par configurer les adresses IP des interfaces:

  • R1
     Router(config)#hostname R1
     R1(config)#interface g0/0
     R1(config-if)#ip address 192.168.1.1 255.255.255.0
     R1(config-if)#no shutdown
     R1(config-if)#interface g0/1
     R1(config-if)#ip address 10.0.0.1 255.255.255.252
     R1(config-if)#no shutdown
     R1(config-if)#interface g0/2
     R1(config-if)#ip address 10.0.0.5 255.255.255.252
     R1(config-if)#no shutdown
  • R2
     Router(config)#hostname R2
     R2(config)#interface g0/0
     R2(config-if)#ip address 172.18.1.1 255.255.255.0
     R2(config-if)#no shutdown
     R2(config-if)#interface g0/1
     R2(config-if)#ip address 10.0.0.2 255.255.255.252
     R2(config-if)#no shutdown
     R2(config-if)#interface g0/2
     R2(config-if)#ip address 10.0.0.10 255.255.255.252
     R2(config-if)#no shutdown
  • R3
     Router(config)#hostname R3
     R3(config)#interface g0/0
     R3(config-if)#ip address 10.0.0.6 255.255.255.252
     R3(config-if)#no shutdown
     R3(config-if)#interface g0/1
     R3(config-if)#ip address 10.0.0.9 255.255.255.252
     R3(config-if)#no shutdown
  • Configuration PC1 et PC2:

    On affecte l’IP 192.168.1.2 avec le masque 255.255.255.0 et comme passerelle 192.168.1.1 à PC1 et l’IP 172.18.1.2 avec le masque 255.255.255.0 et comme passerelle 172.18.1.1 à PC2.

Passons à la configuration du routage OSPF:

  • R1
    R1(config)#router ospf 1
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
    R1(config-router)#network 10.0.0.1 0.0.0.0 area 0
    R1(config-router)#network 10.0.0.5 0.0.0.0 area 0
    
  • R2
    R2(config)#router ospf 1
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 172.18.1.0 0.0.0.255 area 0
    R2(config-router)#network 10.0.0.2 0.0.0.0 area 0
    R2(config-router)#network 10.0.0.10 0.0.0.0 area 0
  • R3
    R3(config)#router ospf 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#network 10.0.0.6 0.0.0.0 area 0
    R3(config-router)#network 10.0.0.9 0.0.0.0 area 0

 

Test

Réalisez les vérifications ci-dessous afin de valider que votre configuration fonctionne:

Commencez par faire un ping entre vos deux machines:

Si vos équipements peuvent communiquer ensemble c’est bon signe. Sinon effectuez les vérifications ci-dessous:

  • R1
    R1#show ip route

La table de routage doit contenir:

O 10.0.0.8/30 [110/2] via 10.0.0.2, 00:06:50, GigabitEthernet0/1
[110/2] via 10.0.0.6, 00:06:50, GigabitEthernet0/2

172.18.0.0/24 is subnetted, 1 subnets
O 172.18.1.0/24 [110/2] via 10.0.0.2, 00:06:50, GigabitEthernet0/1
  • R2
    R2#show ip route

La table de routage doit contenir:

O 10.0.0.4/30 [110/2] via 10.0.0.1, 00:07:39, GigabitEthernet0/1
[110/2] via 10.0.0.9, 00:07:39, GigabitEthernet0/2

O 192.168.1.0/24 [110/2] via 10.0.0.1, 00:07:39, GigabitEthernet0/1

  • R3
    R3#show ip route

La table de routage doit contenir:

O 172.18.1.0/24 [110/2] via 10.0.0.10, 00:08:51, GigabitEthernet0/1


O 192.168.1.0/24 [110/2] via 10.0.0.5, 00:09:17, GigabitEthernet0/0


O 10.0.0.0/30 [110/2] via 10.0.0.10, 00:08:51, GigabitEthernet0/1

[110/2] via 10.0.0.5, 00:08:51, GigabitEthernet0/0

 

Le « O » devant les routes symbolise que celles-ci ont été apprises par le protocole OSPF. Vous pouvez déconnecter des câbles réseaux afin de voir les mises à jour de la table de routage de vos équipements.

 

C’est la fin de ce tutoriel sur le protocole de routage dynamique OSPF, n’hésitez pas à consulter mon article sur le routage statique ou celui sur le routage dynamique RIP, si vous souhaitez en savoir d’avantage.

À propos de l’auteur

Vincent Krahenbuhl administrator

Passionné d’informatique, ma motivation et ma curiosité m’ont permis de réaliser des études en alternance, tout d’abord en tant que technicien informatique au sein du groupe Edscha puis administrateur réseau au sein de FM Logistic. Fort de ces expériences dans deux entreprises internationales, j’exerce aujourd’hui le rôle d’ingénieur réseau et sécurité chez FM Logistic.

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.